Server requirements for Hosting WordPress

Posted on January 21st, 2011

WordPress Versions Php Version Mysql   Version Apache
3.2 5.2 or greater 5.0.15 or greater mod_rewrite module for permalinks(optional)
2.9, 3.0, 3.1 4.3 or greater 4.1.2 or greater mod_rewrite module for permalinks(optional)
2.5, 2.6, 2.7, 2.8 4.3 or greater 4.0 or greater mod_rewrite module for permalinks(optional)
2.1, 2.2, 2.3 4.2 or greater 4.0 or greater mod_rewrite module for permalinks(optional)
2.0 4.2 or greater 3.23.23 or greater mod_rewrite module for permalinks(optional)

*WordPress uses the Apache module mod_rewrite to implement its permalink system. Permalinks are highly recommended in wordpress for the cleanliness of URL.